|
|
|
|
公众号矩阵
创建专栏

福昕阅读器爆出多个任意代码执行漏洞

福昕软件(Foxit Software)本周发布了福昕PDF阅读器和PDF编辑器的安全更新,用于解决导致远程代码执行的多个漏洞。

作者:安全牛|2021-07-29 15:57

福昕软件(Foxit Software)本周发布了福昕PDF阅读器和PDF编辑器的安全更新,用于解决导致远程代码执行的多个漏洞。

这些远程代码执行漏洞被跟踪为CVE-2021-21831、CVE-2021-21870 和CVE-2021-21893,由Cisco Talos研究人员发现。

其中CVSS的严重性评分为8.8。由于某些JavaScript代码或注释对象的处理方式,恶意制作的PDF文件可能会导致重复使用以前空闲的内存和任意代码执行。

攻击者可以通过欺骗目标用户打开恶意PDF文件来利用该漏洞。根据Cisco Talos的公告,如果受害者启用了Foxit的浏览器插件,攻击者还可以通过恶意网站利用该漏洞。

福昕软件还解决了应用程序处理某些PDF文件中的注释对象的漏洞。

福昕软件解释说,当Annotation字典有多个关联的注释对象并且可能导致远程代码执行时,就会出现漏洞。

更新所解决的另一个安全问题是,用户在浏览完某些PDF文件中的书签节点后,释放时也可能导致远程代码执行。

福昕软件还解决了具有过多嵌入节点的XML数据、执行submitForm函数或解析特制PDF文件相关的潜在安全问题。

福昕软件还发现其中一些漏洞会影响Foxit应用程序的macOS版本,并且还为它们发布了补丁。

【本文是51CTO专栏作者“安全牛”的原创文章,转载请通过安全牛(微信公众号id:gooann-sectv)获取授权】

戳这里,看该作者更多好文 

【编辑推荐】

  1. 奥运会再次成为黑客攻击目标,专门针对日本电脑,文件会被删除
  2. 论漏洞管理平台的自我修养
  3. 主动学习在网络攻击识别中的应用简介
  4. DDoS攻击规模远超往年
  5. 还原Cloudflare CDN 漏洞被利用的过程
【责任编辑:赵宁宁 TEL:(010)68476606】

点赞 0
分享:
大家都在看
猜你喜欢